Toyota Nation Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
!ALERT! English is not my first language.
Greetings from Finland everyone!

So about 3 weeks or so ago i bought my very first MR2. It's 1994 2.0l 175hp Non aspirated 3S-GE.

!Warning! This going to be long story bro.
After purchase i was driving my MR2 home. After 30km i stopped to gas her up. Immediately after fill up i started the car and saw the CEL flash few times. It went away and i thought nothing about it. I drove another 60km to home without any problems.

Next day i noticed unusual behavior when the car was idling. At times it had problems with idle stalling a bit but did not shutdown. Later that day while driving to the traffic lights the car started flashing the CEL and the car had lot's of problems staying idling. Most of the time when i revved it above 3k while in traffic lights the CEL light went off and i was able to drive it normally. While driving, when ever the RPM went to 2-2,5k i felt very strong jerking movement. All most like the car didn't get fuel or the ignition did not fire up.

I decided to go ahead and drive to my friends garage to inspect the car. about 70km mostly highway. Car worked just fine. Just when i arrived at my mates house the CEL light lit up and stayed on no matter what i did. Revving above 3k did not take away the problem as the car would not rev past 3200.

I searched the internet how to read the problem code with a pin through E1 and TE1. I got a code 14. No IGF signal to ECU 8 - 11 times in succession.

I left the car there thinking it has to be ignition problem. I ordered new spark plugs, rotor arm and distributor cap. Days later i went to my mates garage and we changed the spark plugs. (Old ones were pitch black), and rotor arm. I couldn't change the distributor cap as Toyota sold me a wrong one. Mine uses 5mm plugs and they sold me the one with 7 or 8mm plugs.
So after changing spark plugs and the rotor the car started right up and the CEL went off and the car was able to rev past 3k. Worked flawlesly so i drove it home 80km without ant problems.
I figured once i get the right distributor cap im done troubleshooting the car.

Next day after coming home from the work i was sitting in traffic lights. I saw a CEL flash few times and i was like bitch pleaseeeee........So managed to get 5 meters away from my parking spot and the CEL light lit up and i started having problems with idling and it felt like i have kangaroo gasoline in the tank when trying to drive the damn thing. All so the car would not rev past 3200

I waited few days and changed the distributor cap thinking all is fine after that. NOPE. Absolutely nothing changed. I checked the spark plugs we installed and after 130km drive they were pitch black again. Those exhaust pipes are all so covered with pitch black goo. So i had extra four spark plugs i got from Toyota and installed them but it did not make any difference at all. I tried to read the problem code again and i just got a steady blinking light like forever. I checked and apparently it means there is no problem with the car. It's totally bizzare as the check engine light lights up less than 0.5 seconds after starting the car.

Car has massive problems idling when cold but once it warms up it can idle fairly well. For some strange reason when ever i gently press the gas so that i get roughly 1200rpm the car is _ hair away from choking. It stays on but it is trying really hard to shut down. Once i press more gas and it goes over 1200rmp it runs pretty fine but still wont take over 3200rpm.

Today i took a gamble and drove the car to my work place garage and it still had the same problems and i noticed that no matter how hard i go on the gas pedal it wont rev past 3200 and it feels like it has no power what so ever. going from 1500rpm to 3000 pedal in the metal has limited power. Feels like the car is in some kind of "limp home mode".

After getting to the garage, i took the throttle body to pieces and everything was covered with black goo. Even inside the "intake manifold?" I will attach a photo provided i know how to. Sorry about this.
So i clean the throttle body, what i can from the intake manifold and i clean the throttle body sensor, and the other sensor that name i cant or don't know how to type in English. Sorry. Something to do with idling. sensor kind of thing.

So while i was doing that i figured i am going to look how the coil and ignition module are doing. I noticed that the under side of the coil (contackt surface) had massive rust/corrosion on it and the metal piece that supposedly ground the whole thing to the body of the car was all so completely rusted. Cleaned those both very well from all the rust. I put everything back together hoping there would be even a slight improvement but NO! No change what so ever.

Now i have ordered new HT leads and the coil and the ignition module. Still waiting for those. Any ideas?

It took me a good hour and half to type all this with the aid of google translate. Holy crap this was painful. If you have any questions or i did not make my self clear just ask and i do my best to try to wright it again. And if the pictures wont show please tell me how to do it as im no computer wizz.

Thank you in advance
-Niko-
282722
 
1 - 1 of 1 Posts
Top