Toyota Nation Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
aight, i'm pretty new to toyotas, and this is the first obd-2 one that i've owned. the problem is that i'm getting a CEL (check engine light) any time that i turn on the truck. I already checked to make sure the gas cap is tight, as i read this is a common problem. i'm wondering if anyone knows of any ways to read these codes, or if the only option is a dealer/expensive scan tool. really need to get this light off, the ms. is too worried to drive it.. thanks for any help that you might have to offer!
 

·
This Space For Rent
Joined
·
13,964 Posts
Not sure if Hawaii has any AutoZones out there, but they can pull codes for you for free. If not, try pulling the 15 amp EFI fuse (the little one, not the big one) for 10 minutes then replace it and see if that clears the CEL. If it comes back, then I would get it checked.

Did you do any mods to your rig before you got the CEL?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Unfortunatly we have no autozones in hawaii, i will try pulling the fuse to see if that solves the problem, hopefully it will. i don't seem to notice anything weird about the car, driveability wize, it seems fine, idles fine, ect. So there isn't any ghetto way to read the codes?
 

·
This Space For Rent
Joined
·
13,964 Posts

·
Pondering the choices
Joined
·
112 Posts
ya

youd need a scan tool to erase the coads other wise they stay in the computer on the obd2. you cant just pull fuse and erase. Back home thats how they do emitions....and code stored and you fail.. you might want to get a scantool
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top