Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Drivers side low beam is not working on a 99 camry. Fuse #17 looks good and no apparent loose wires or connectors.

I believe the car uses a single bulb for the hi and low beams. Is the bulb bad if the low beam doesn't work?
 

·
Banned
Car
Joined
·
417 Posts
one bulb is for high beam and another for low beam.if you stand in front of car,the right bulb is for low beam and the left bulb is for high beam
 

·
I wrench, therefore I am!
Joined
·
1,630 Posts
one bulb is for high beam and another for low beam.if you stand in front of car,the right bulb is for low beam and the left bulb is for high beam
?????????????????????????????

The 99 uses a single combination lamp.

OP is correct. When the low filament goes, you toss the single bulb. Low almost always goes first, unless maybe if you live in AK or NWT.
 

·
Banned
Car
Joined
·
417 Posts
i own gen 4,but mine is so.i think there is some difference between American cars and middle east car.
i apologies if i made a mistake.
 

·
Registered
Joined
·
145 Posts
its called dual filament....remove it and look at it....you can pretty easily see if one of the filament wires/coils has broken......chances are, thats the low beam....fords have this problem....they compound by making it worse with the fact you can tap on the light housing and the light comes back on...usually about 2-3 weeks later, the whole bulb goes out.....

just replace it...its a cheap fix
 
1 - 6 of 6 Posts
Top