Toyota Nation Forum banner

1 - 7 of 7 Posts

·
Registered
1993 Camry LE
Joined
·
172 Posts
Discussion Starter #1
Since I bought my car the radiator is always on, from the moment I turn on the car until the moment I turn it off. I checked the wires for any rigging but have not found any. Mind you I'm a noob when it comes to any electrical work outside of the standard radio and amp install.

Could it be a rig? Bad sensor/thermo? Radiator gremlins out to kill my beloved Camry?
 

·
TN's Resident Car Whore!
'95 DSM Eclipse RS
Joined
·
5,979 Posts
Same thing on my car, as i turn it one the fans come on and they don't come off until I turn off.
 

·
Registered
1993 Camry LE
Joined
·
172 Posts
Discussion Starter #5
5spd V6 ClrTail said:
Man, if you have the previous V6 models, the fan isn't electric. It's designed to be "on" like that.
It's an I4.


karazy said:
It is probably the thermo. unplug it and bridge it, if it shuts off change the sw/.
eh, could you go into a little more detail?
 

·
I'm a Mac
DD - 94 Mitsu 3000GT
Joined
·
4,062 Posts
check your thermostat. check your radiator fan relays, this is most likely the issue.

for info on how to do it, go buy a haynes manual for your car. you can find them at any local autoparts store.
 

·
Registered
1993 Camry LE
Joined
·
172 Posts
Discussion Starter #7
Got the manual, I just honestly haven't had time to start trouble shooting the problem. Figured I would get a head start here and *hopefully* get started on it in the morning.
 
1 - 7 of 7 Posts
Top