Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I need some serious help with 1989 Toyota 4 cylinder 4x4 pickup. The engine starting heating up and we had oil in the coolant and sludge in the oil. We replaced with a new head and it's still heating up and we still have the sludge in the oil. Can anyone help with this matter? Do I just need to trash the pickup? Any help with this would be greatly appreciated!
Thanks!! L.R.
 

·
5M-GE
Joined
·
2,901 Posts
Flashmn said:
maybe a warped block.
you checked for that, I hope?

Was it a proper HG job? or was it old head out, HG in, new head in?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Actually we had someone do it for us but of course found out that he's a little shoddy. So I probably just lost 700.00 dollars. The oil still looks milky and we're also getting oil in the coolant. We've flushed it twice. Does it take awhile to get all the water out? It looks like I just got screwed!! That's the way my luck is! Let me know. Thanks
L.R.
 

·
Registered
Joined
·
195 Posts
if its not a warped block, the head gasket was sub-standard or maybe the one who placed it, removed it after it has been bolted , as a result the head gasket become damaged. Or maybe its the gasket maker he is using.
 

·
5M-GE
Joined
·
2,901 Posts
Weenies3 said:
Actually we had someone do it for us but of course found out that he's a little shoddy. So I probably just lost 700.00 dollars. The oil still looks milky and we're also getting oil in the coolant. We've flushed it twice. Does it take awhile to get all the water out? It looks like I just got screwed!! That's the way my luck is! Let me know. Thanks
L.R.
Looks like you've got another head gasket gone. :(
 
1 - 6 of 6 Posts
Top