Toyota Nation Forum banner

rough idle when cooling fan turns on

1590 Views 6 Replies 3 Participants Last post by  styran
my matrix 2azfe once warmed up will idle low when the rad fan turns on.
so low that the engine starts to shake which shakes the shifter as well. it never stalls but the shifter starts to shake like crazy which is quite irritating.
this only happens after the cars warmed up enough that the cooling fan needs to come on to stop the car from overheating in traffic. it also happens randomly after the car is started after being warmed up first.
this makes me have to give the car gas so the car doesn’t idle to low. this happens only in N. no CEL or any codes.

what could be wrong?
1 - 7 of 7 Posts

· Registered
2010 Matrix 2.4L
Joined
·
7 Posts
Discussion Starter · #3 · (Edited)
Try cleaning the throttle body, the throttle gets gunk around it that makes it stick when the computer is trying to fine tune the idle.
thanks for the suggestion. i did this a couple days ago and the throttle body was pretty dirty. after cleaning it and driving the car for a couple days the problem still happens. i’m not sure if it’s an electrical or mechanical issue. i have already cleaned the MAF sensor and replaced the air filter and still no results
Household hardware Gas Auto part Electric blue Nickel

i pulled a spark plug and it looked like this. plugs have about 30k miles on them
 

· Registered
Joined
·
1,246 Posts
Did you get a rag and manually clean the throttle body? That gunk is hard to clean off completely. What rpm does the engine normally idle at? There is an idle relearn procedure that I’ve seen posted on Toyota nation. You could also do a compression check to rule out a failing head gasket.
 

· Registered
2010 Matrix 2.4L
Joined
·
7 Posts
Discussion Starter · #5 ·
Did you get a rag and manually clean the throttle body? That gunk is hard to clean off completely. What rpm does the engine normally idle at? There is an idle relearn procedure that I’ve seen posted on Toyota nation. You could also do a compression check to rule out a failing head gasket.
I'm pretty sure the throttle body is relatively clean. I sprayed & wiped so much cleaner the car ran like shit for ten minutes and threw tons of misfire codes.
Idle is usually @ 650rpm and the car shakes when it drops to 500rpm when the rad fan turns on.
 

· Administrator
マズダスピード3
Joined
·
18,219 Posts
Did you notice any sticking after cleaning the throttle plate? Over time, the plate can get loose and will have slack during operation. If you have drive by wire, I don't know if there's a way to adjust it. On the throttle cable models, 03-04 you can try to tighten or loosen the set screw for the throttle plate. But you can only adjust so much before it isn't working to remove the slack.
 

· Registered
2010 Matrix 2.4L
Joined
·
7 Posts
Discussion Starter · #7 ·
Did you notice any sticking after cleaning the throttle plate? Over time, the plate can get loose and will have slack during operation. If you have drive by wire, I don't know if there's a way to adjust it. On the throttle cable models, 03-04 you can try to tighten or loosen the set screw for the throttle plate. But you can only adjust so much before it isn't working to remove the slack.
the throttle body is electronic
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top