Toyota Nation Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have an 88 4 runner 22re 5spd. I recently replaced the clutch, pressure plate, throw out bearing, master and slave cylinder, distributor, ignition control module, ignitor coil.

Truck started up with a misfire....when I took it out to test drive to see how the trans was and how it was shifting the truck shut off coming up to a red light. Went to turn the ignition the truck would crank but wouldn’t turn over unless I gave it a little gas....I suspect maybe because it’s been sitting for awhile that the fuel might be bad so I added like a fuel additive until I can get fresh fuel for it. On the other hand I hear that it maybe a bad fuel pump. I was just curious on what some of your guys’ thoughts were?


Sent from my iPhone using Tapatalk
 

·
Moderator
1998 T100 SR5 2WD
Joined
·
13,623 Posts
Is the Check Engine light on? If so, did you pull the codes? If you did, what were the exact numbers you pulled? ;)

You could measure the fuel pump motor with a multimeter and post up the resistance value you git. Have you checked or replaced the fuel filter since it's been sitting fer some time? Did you perform a fuel pressure test? It would probably give you a better indication if the fuel pump was working correctly. ;)

How good are the rest of the ignition components like the spark plugs, wires, rotor and cap? ;)

Did you inspect the air filter fer any restrictions? How good is the VAFM? Is it sticking? ;)

Have you inspected the cold start injector or the fuel injectors? ;)
 
1 - 2 of 2 Posts
Top