Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
@ Toyota Allex drivers (EDIT: The Toyota Allex is similar to the Gen 9 Corolla).

Has your Allex ever revved but barely accelerated (sometimes)? Like when at a stoplight and take off?

Went to a mechanic and he scanned and said it’s either the speed sensor or maf..

Has anyone else had this issue?
 

·
Super Moderator
Joined
·
13,486 Posts
That model isn’t sold in the USA, so not many of our members are familiar with it.
 

·
Moderator
Various Toyotas
Joined
·
4,895 Posts
Apparently it is very similar to the Gen 9 (and possibly very late Gen 8) Corolla. I will move this thread to that forum for the time being.

It would help if you told us what year your Allex (Corolla) is and if it's manual transmission. Also, what engine size? The Allex came in six different sizes from a 1.3 to a 2.0 and was also available in the 2ZZ and in diesel configurations as well.
 

·
Registered
Joined
·
488 Posts
MAF can be checked relatively easily, just unplug it while the motor is running. If the motor keeps running, your MAF is toast. The engine should just stall right as you unplug the MAF....
Not sure how a speed sensor would do anything to the engine performance. That doesn't make any sense to me... If it's a manual and your revs are rising and the car is barely accelerating, most likely the clutch is bad.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Apparently it is very similar to the Gen 9 (and possibly very late Gen 8) Corolla. I will move this thread to that forum for the time being.

It would help if you told us what year your Allex (Corolla) is and if it's manual transmission. Also, what engine size? The Allex came in six different sizes from a 1.3 to a 2.0 and was also available in the 2ZZ and in diesel configurations as well.
It is a 2004 Toyota Allex, 1.8l, Gas, automatic transmission with a 1zz engine
 

·
Moderator
Various Toyotas
Joined
·
4,895 Posts
1 - 6 of 6 Posts
Top