Toyota Nation Forum banner
1 - 14 of 14 Posts

·
damnjapanfan
Joined
·
32 Posts
Discussion Starter · #1 ·
for the past few days now,my 94 camry wagon has started up okay and goes into reverse and drive fine.i've noticed though that once i step on the gas it feels sluggish and slower then usual for a few (just until i get down the block in my neighborhood)i find that if i pull over for a sec and put it in park and let it sit for a minute while lightly reving the engine that it seems to help.no lights have come on or anything.i am thinking that it is need of a transmission flush but wanted to rule out any other possibilities.Any advice is greatly appreciated.thanks!
 

·
Mad Scientist
94 scepter coupe
Joined
·
3,960 Posts
fuel filter was replaced 6months ago
injectors are fine and the oil was just changed

the motor is fine when it's in park or neutral the thing revs up like nothing but when we first start it in the morning it moves sluggish i know it's not the motor. it started happening after we arrived here in pembroke pines
 

·
Premium Member
96 Camry Coupe
Joined
·
1,291 Posts
2wickedtoyz said:
fuel filter was replaced 6months ago
injectors are fine and the oil was just changed

the motor is fine when it's in park or neutral the thing revs up like nothing but when we first start it in the morning it moves sluggish i know it's not the motor. it started happening after we arrived here in pembroke pines
You just moved or what? Is there a difference in altitude? Where is the temp. gauge at when this happens? And when it doesen't?
 

·
Mad Scientist
94 scepter coupe
Joined
·
3,960 Posts
no i'm just visiting family. the car used to be fine oil pressure is at 20psi volts are at 14.5 and temp is 3/8ths of the way up when it's normal but it only does this speraticly and it freaks me out but wed we're getting a flush so i'll let you guys know how it went
 
2005 Tacoma X-Runner
Joined
·
9,188 Posts
Oh, reminds me of my streetbikes. The engine isn't completely warmed up and there is blowby. Sounds like the piston rings are getting worn. I wouldn't worry about it too much, just let it warm up and don't supercharge/tc it without installing new piston rings.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top