Toyota Nation Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter #1
Guys,

Need help with my toyota 4 cylinder, 8 valves, carbed engine. I have started the engine and whenever I stop it, it still runs after a few seconds then smokes comes out of the carb intake.

Thanks,
Rey
 

·
poor college student
Joined
·
1,368 Posts
sounds like the fuel isn't shutting off and you are still getting spark to ignite the fuel

clean and lube up the carb maybe?
 

·
Registered
Joined
·
195 Posts
Discussion Starter #4
Its a distributor type engine. another problem is that engine sputters when given a brief accelerator pumps, and it dies if I keep on giving it frequent brief pumps. The engine doen't have any power until I pressed the accelerator steadily for 4 seconds.
 

·
Registered
Joined
·
195 Posts
Discussion Starter #6
The engine has a hot plug installed and the plug has some carbon build-up. Are you suggesting that I use a colder plug?
 

·
^
Joined
·
4,197 Posts
Some carbon buildup wouldn't be enough, it would have to be quite a bit in the combustion chamber, most likely on the valves. It wouldn't hurt to clean them up and check your timing.
 

·
Registered
Joined
·
195 Posts
Discussion Starter #8
Mr. Deep, I am planning to re-timmed my corolla (toyota 4k engine) this weekend but I don't have a guide on plug, contact point and valve lash clearances. Do you happen to know the factory specs for the said model?
 

·
^
Joined
·
4,197 Posts
Not a clue, lemme move this to the 'rolla forum. You may want to start a new thread asking what the timing is for a 4K.
 
1 - 9 of 9 Posts
Top