Toyota Nation Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I bought a used Solara few months back and it looks like the previous owner did not care for it too well. I was replacing one of the hoses going from the throttle body to the air intake, and I realized that I am missing the Vehicle Speed Sensor. There is a plug in its place that looks like it was there since the beginning, but I am not sure if an actual sensor is supposed to be in its place. There is no loose connector anywhere that would look like it goes to VSS. Based on the wiring diagrams, the sensor is supposed to be right there, but it is not. I went to the junkyard and took a look at the 2005 Camry and got myself the VSS and its connector, traced the wires themselves to the passenger side wiring harness. However, when I took the insulation off on my vehicle's harness, I could not find any loose wires either at all. The main reason that I think that this is an issue is because my cruise control does not work and my car shifts pretty rough. Does anybody know if the sensor is supposed to be there or if this model is any different from the 02-06 Camry's (that's what my manual covers, as well as Solara 02-08)?
 

·
Registered
1995 T100 2WD
Joined
·
3,849 Posts
I bought a used Solara few months back and it looks like the previous owner did not care for it too well. I was replacing one of the hoses going from the throttle body to the air intake, and I realized that I am missing the Vehicle Speed Sensor. There is a plug in its place that looks like it was there since the beginning, but I am not sure if an actual sensor is supposed to be in its place. There is no loose connector anywhere that would look like it goes to VSS. Based on the wiring diagrams, the sensor is supposed to be right there, but it is not. I went to the junkyard and took a look at the 2005 Camry and got myself the VSS and its connector, traced the wires themselves to the passenger side wiring harness. However, when I took the insulation off on my vehicle's harness, I could not find any loose wires either at all. The main reason that I think that this is an issue is because my cruise control does not work and my car shifts pretty rough. Does anybody know if the sensor is supposed to be there or if this model is any different from the 02-06 Camry's (that's what my manual covers, as well as Solara 02-08)?
If it was missing you should have a DTC code. Also I was under the impression that it was located on top of the transmission but visible from looking in the engine bay. Sold my Solara many years ago.
 
1 - 2 of 2 Posts
Top