Toyota Nation Forum banner

1 - 11 of 11 Posts

·
Ms. Gayle (aka Jew-Lo)
Joined
·
236 Posts
Discussion Starter #1
i dont know what the problem with the car is... as you remember i had posted before about me changing the plugs and the fuel filter... everything was going smoothly but yesterday when i turned the car on it was having trouble starting it was making funny sounds... do u think it could be the plugs not starting a spark? they were gapped from the package not with a gapper so should i get new plugs again?
 

·
Registered
Joined
·
238 Posts
where they bosch plugs?...toyotas and most jnese vehicles don't run well with the bosch plugs. usually volkswagon and some european cars run good with them.
 

·
Ms. Gayle (aka Jew-Lo)
Joined
·
236 Posts
Discussion Starter #3
i really cant remember what they were- i know they were from pep boys in an orange package- and like 5$ in total
 

·
Registered
Joined
·
136 Posts
RedHawk said:
i dont know what the problem with the car is... as you remember i had posted before about me changing the plugs and the fuel filter... everything was going smoothly but yesterday when i turned the car on it was having trouble starting it was making funny sounds... do u think it could be the plugs not starting a spark? they were gapped from the package not with a gapper so should i get new plugs again?
 

·
Registered
Joined
·
136 Posts
Re: Re: spark plugs

whoops, trigger finger,
whenever you change a fuel filter, the first time you start it it will seem to take forever to start because fuel has to run through first. How does it run after starting and warming up? To be safe, take plugs out and gap should be .044in. sometimes plugs gapped from manuf. are smashed down from shipping whatnot. Make sure where wiring for coil packs connects, make sure you didn't get the connectors switched around. Make sure wires aren't touching as best as possible and all boots are tight on plugs and snapped into place. all i can think off, ANDY
 
2005 Tacoma X-Runner
Joined
·
9,188 Posts
If you got plugs in an orange package they are prob. the wrong ones. The only ones you want to use are the ngk laser platinums or the denso platinums. And they will prob. cost about 11 bucks each.
 

·
Ms. Gayle (aka Jew-Lo)
Joined
·
236 Posts
Discussion Starter #7
ythats way too much money
the car is doing a lot bette rnow so im guessing its just a fluke
 
2005 Tacoma X-Runner
Joined
·
9,188 Posts
Yeah they're expensive but they last 60-90k miles. And it is what is required for the engine.
 
2005 Tacoma X-Runner
Joined
·
9,188 Posts
You know what I just realized you had a tercel. I think they're regular plugs, nevermind what i said.:hammer:
 

·
Ms. Gayle (aka Jew-Lo)
Joined
·
236 Posts
Discussion Starter #11
what did u think i had? a rocket ship?
i was gonna say its a tercel not a super duper car :lol:
 
1 - 11 of 11 Posts
Top