Toyota Nation Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I have 92 Camry (3VZ-FE 168000km).
Problem:

When I drive around 20-80Km/Hour, the needle wanders 20-40Km/hour. The needle of speed meter never point to the accuracy data. If I drive around 100KM/Hour, The needle point to Zero and stays over there. Now, My crouise not work at all.

I doubt a couple of issues. The First One is speed sensor. The Second one is cable issue. the third one is the speed meter issue.

I can not buy those three parts, then try one by one to find out the problem. I Can remove the Speed sensor from trans.

Question One,
Does any one can tell me, how to test the speed sensor is good or not?
Question Two,
If I fix the issue, the cruise will come back to work automatically?

Thank You Gus.

Jason
 

·
V8'sRGone
95 Cam
Joined
·
1,956 Posts
I have 92 Camry (3VZ-FE 168000km).
Problem:

When I drive around 20-80Km/Hour, the needle wanders 20-40Km/hour. The needle of speed meter never point to the accuracy data. If I drive around 100KM/Hour, The needle point to Zero and stays over there. Now, My crouise not work at all.

I doubt a couple of issues. The First One is speed sensor. The Second one is cable issue. the third one is the speed meter issue.

I can not buy those three parts, then try one by one to find out the problem. I Can remove the Speed sensor from trans.

Question One,
Does any one can tell me, how to test the speed sensor is good or not?
Question Two,
If I fix the issue, the cruise will come back to work automatically?

Thank You Gus.

Jason
You posted about this same issue in another thread. TN people are willing to help, but you have to provide information. IIRC I gave you the link which provides the Toyota Factory Service Manual which tells you how to test the sensors.
Please follow the link. . . This means you have to do some work to and that might include having someone help you read and interpret this.
 

·
抵抗しても無駄だ
2002 Solara SLE V6
Joined
·
9,090 Posts
most likely the Vehicle Speed Sensor sitting on top of differential body is going bad. check the wiring first though, refer to FSM links for diagnostics that 73sport posted (wherever the other thread is).
 

·
RX-7 Restorations
18 Camry SE
Joined
·
1,570 Posts
the first camry that i owned was a 92 XLE with the 3VZ-FE and the 4spd auto trans. my speedometer did the same thing you are describing. i removed the speedometer drive gear from the top of the transmission and found that it was missing a couple or a few teeth. once replaced everything was back to normal. i suggest removing the speedo gear and inspecting it for breakage and or wear.
 
1 - 4 of 4 Posts
Top