Toyota Nation Forum banner

1 - 14 of 14 Posts

·
Registered
1996 Toyota T-100 3.4L V6 extended cab SR5 4x4
Joined
·
85 Posts
Discussion Starter #1
I’m looking for a stock radio with cassette player. Does anyone know where I can find one at? Thanks a lot
 

·
Registered
1997 T100 SR5 4x4
Joined
·
111 Posts
He's right, check out Flea Bay, I picked up one there for mine but it was listed as coming out of a Corolla, just check the numbers on yours to the ones on the radio you are looking at. Mine were an exact match so I got it, it ran a little cheaper than ones listed for the T100 at the time. Good luck.

Steve...........
 
  • Like
Reactions: k294

·
Registered
1996 Toyota T-100 3.4L V6 extended cab SR5 4x4
Joined
·
85 Posts
Discussion Starter #4
  • Like
Reactions: Heliroy

·
Registered
Joined
·
28 Posts
The belts wear out(stretch or break) on the CD and cassette players this old. Hopefully they work for you! I haven't had much luck..
 

·
Registered
1996 Toyota T-100 3.4L V6 extended cab SR5 4x4
Joined
·
85 Posts
Discussion Starter #6
The belts wear out(stretch or break) on the CD and cassette players this old. Hopefully they work for you! I haven't had much luck..
It says free returns within 30 days so we will see. I’ll let y’all know. I just don’t want an aftermarket radio with CD player. I still use cassettes
 

·
Registered
1996 Toyota T-100 3.4L V6 extended cab SR5 4x4
Joined
·
85 Posts
Discussion Starter #9

·
Moderator
1998 T100 SR5 2WD
Joined
·
14,129 Posts
Are you sure the balance/fader isn't turned to the right rear side only? ;)
 

·
Registered
1996 Toyota T-100 3.4L V6 extended cab SR5 4x4
Joined
·
85 Posts
Discussion Starter #11 (Edited)
Are you sure the balance/fader isn't turned to the right rear side only? ;)
Yes I turned it all the way to the left and nothing. This truck sat with windows down for 3 years and went through hurricane Harvey and numerous other storms. For a while a goat lived there. So I’m thinking water got into the internal amp. I just don’t know if the one I posted is the right one.
306358
306359
 

·
Moderator
1998 T100 SR5 2WD
Joined
·
14,129 Posts
I can always pull the amp out of my T-100 since I'm not using it. ;)

There's also a possibility that the radio may not be working correctly either. Have you checked the wiring harness to the speakers? Are you sure the speakers are working correctly? You can test the speakers with a 9V battery. You should see the cone move and hear a small pop when you connect the leads to the 9V battery. ;)
 

·
Registered
1996 Toyota T-100 3.4L V6 extended cab SR5 4x4
Joined
·
85 Posts
Discussion Starter #13
I can always pull the amp out of my T-100 since I'm not using it. ;)

There's also a possibility that the radio may not be working correctly either. Have you checked the wiring harness to the speakers? Are you sure the speakers are working correctly? You can test the speakers with a 9V battery. You should see the cone move and hear a small pop when you connect the leads to the 9V battery. ;)
I feel like an idiot but I never knew you could pull the volume knob out to adjust fader. It’s fixed lol
 
1 - 14 of 14 Posts
Top