Toyota Nation Forum banner

1 - 11 of 11 Posts

·
Registered
SLK & MR2
Joined
·
33 Posts
Discussion Starter · #1 ·
wassup guys... this is prolly' the 2nd time ive posted this.. so ive picked up the mr2 from the shop and they said that the cable for my gas pedal isnt the problem... i drove it last nite and that sucker was still stiff.. they even lubricated the cable, cleaned up the throttle and nothing happened..

any other advice here???

thanx fellaz!!
 

·
Young At Heart
1993 Mr2
Joined
·
463 Posts
yip

Agreed.... this could very well cause a tight pedal. Also check all the obvious things first, like (if anything is under the pedal)..... sometimes it is simple things that catch u by suprise after u check all the hard things. Follow the line all the way back to where it ends, then if this doesn't fix the problem, think of all the things that open and close due to pressing the throttle.
 

·
Registered
SLK & MR2
Joined
·
33 Posts
Discussion Starter · #6 ·
ez ez ez... well, they specifically told me that that has always been the mr2's problem... and driving the car around today, the CHECK ENGINE "lit" all of a sudden.. would that only be the sensor??
 

·
Premium Member
'91 MR2 Turbo
Joined
·
19,831 Posts
9MOON said:
ez ez ez... well, they specifically told me that that has always been the mr2's problem... and driving the car around today, the CHECK ENGINE "lit" all of a sudden.. would that only be the sensor??
#1.) My gas pedal is not sticky and never has been. And I have never heard/seen anyone complain of that problem since I joined TN over 2 tears ago. This is not a problem common to MR2's.

#2.) They don't throw codes for nothin'.. Something is out of whack..
 

·
Young At Heart
1993 Mr2
Joined
·
463 Posts
I agree

I have never heard of this being a common problem, and have never heard this topic brought up b4.... sorry to hear that your c. engine light has come on.... I would definately get it checked out... b4 it might turn into something really bad...
 

·
Audi Technician
91 MR2
Joined
·
774 Posts
9MOON said:
ez ez ez... well, they specifically told me that that has always been the mr2's problem... and driving the car around today, the CHECK ENGINE "lit" all of a sudden.. would that only be the sensor??
an engine code is thrown due to a failure in an emission controlled device...

could it be only a sensor....?

yes, most likely it is... but you have to check the code and find out for sure.

my problem w/ the throttle cable happened when the throttle cable frayed inside the protection and couldn't be seen... i forgot to mention that... but i checked my car records and found the cable and i remembered...
 

·
Registered
SLK & MR2
Joined
·
33 Posts
Discussion Starter · #10 ·
Thanx Knight... just off topic, are u a batman collector as well?? just asked cause i myself used to collect comic books..
 
1 - 11 of 11 Posts
Top