Toyota Nation Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My car engine check light comes on with the engine then losing power drastically and failing to drive. From the codes the fault is knock sensor. Have changed the knock sensor but no improvement. Engine has no signs of knock and sounds fine before light comes on. is there a way to bypass/bridge sensor so as to run engine and assess this problem before i replace the engine. Help am very desperate!!!
 
H

·
Guest
Joined
·
0 Posts
On Sat, 29 Oct 2005 06:45:05 -0400, zimano wrote:

>
> My car engine check light comes on with the engine then losing power
> drastically and failing to drive. From the codes the fault is knock
> sensor. Have changed the knock sensor but no improvement. Engine has no
> signs of knock and sounds fine before light comes on. is there a way to
> bypass/bridge sensor so as to run engine and assess this problem before
> i replace the engine. Help am very desperate!!!



What was the code? I had a Tercel that returned a code for a bad KS, and I
replaced it and it still threw the same code. Took it to an actual Toyota
dealer (luckily, our local dealer only charges 1/2 hour for a code
reading, instead of the 1.5 others charge!) and came back Low EGR flow.

Cleaned the hoses with a spray cleaner from a parts store and it went away.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Code was 52. Actually solved this yesterday. Sensor wire was touching the shield cable around it that prevents pick up of stray signals. Now light does not come on but car does not run smooth and takes time to accelerate. Want to replace the plugs. Anything else i should check??
 
1 - 3 of 3 Posts
Top