Toyota Nation Forum banner

21 - 34 of 34 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #21
the forth coil was super hot, and I think what smoke was coming was from the wire harness that was connected, However, the harness is fine because my car is working fine now!
 

·
Registered
Joined
·
17 Posts
Discussion Starter #25
The ngk spark plugs, they were from advance auto parts! So, they are definitely legit!
 

·
Registered
Joined
·
17 Posts
Discussion Starter #27
having the two rubber grommets on the one coil. could have messed up both coils. However, I didn't notice this when I installed the part. So that could have been a huge issue!
 

·
Registered
Joined
·
17 Posts
Discussion Starter #28
especially because this will increase the space between the ignition boot and the spark plug!
 

·
Registered
Joined
·
586 Posts
if the coil wasn't plugged into the spark plug all the way due to an extra gasket or something and it wasn't making good contact, that would cause the coil to work extra hard and get hot.
 

·
Registered
Joined
·
586 Posts
I would just put the new ones in that they sent you then, maybe there was a bad lot at the factory or something.
 

·
Registered
Joined
·
24 Posts
The first two I bought worked perfectly fine! The seller is sending me brand news ones and its already shipped and he did mention that he buys directly from denso!
There's a lot of fake/counterfit ones being sold out there. Specially plugs and coils (Denso, NGK, Toyota branded, and etc)....

Denso keeps records of authorized sellers. You should contact Denso directly and notify them of of the issue. If Denso finds that the seller is legit, Denso themselves will send you a replacement.

Yes, your NGK plugs are legit since you them from advance auto parts (I believe authrized seller for Denso too). You should have bought your coils from the advance autoparts too.
 
21 - 34 of 34 Posts
Top