Toyota Nation Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hello Everyone

Im having this problem with my corolla , i got the P0172 along with the multiples misfire so i took the MAS air flow and i cleaned it ,
the CEL was gone for 80 Mile , and now the CEL is comeback with new code P0101 and the old one as well ( P0172 + Misfires )
Any body have where should i start ? or what is the problem ? anybody experienced the same problem ?

thanks
 

·
Registered
Joined
·
59 Posts
Hello Everyone

Im having this problem with my corolla , i got the P0172 along with the multiples misfire so i took the MAS air flow and i cleaned it ,
the CEL was gone for 80 Mile , and now the CEL is comeback with new code P0101 and the old one as well ( P0172 + Misfires )
Any body have where should i start ? or what is the problem ? anybody experienced the same problem ?

thanks
Here's a related thread. Make sure that the air filter is clean BTW.

 

·
Registered
05 camry 07 tacoma
Joined
·
2,550 Posts
Suspect May can you post the g/s reading at idle and at 3000 rpm?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Here's a related thread. Make sure that the air filter is clean BTW.

i will put a picture of my air filter on this weekend , Thank you .
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Suspect May can you post the g/s reading at idle and at 3000 rpm?
Hi
How i can the g/s reading at idle and at 3000 rpm ?
i have a regular OBD scanner , i'm not sure how to pull this kind of Data !
thank you
 

·
Super Moderator
2006 Corolla XRS
Joined
·
7,425 Posts
Does your scan tool post live data?
 

·
Super Moderator
2006 Corolla XRS
Joined
·
7,425 Posts
Ok. Your maf reading will be there in the live data. MAF g/s
 

·
Super Moderator
2006 Corolla XRS
Joined
·
7,425 Posts
Something is throwing off your O2 sensors. 10% for STFT and 32% LTFT. when you ran the live data, was the engine at operating temp or was it just a cold start?

The maf looks to be on the low side. Mine is closer to +2 g/s. Have you tried cleaning it?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #14
Something is throwing off your O2 sensors. 10% for STFT and 32% LTFT. when you ran the live data, was the engine at operating temp or was it just a cold start?

The maf looks to be on the low side. Mine is closer to +2 g/s. Have you tried cleaning it?
yes i did cleaned it but i didn't change the air filter or checked it , the engine was at operating temp .
any ideas , i have the data when the engine was cold as well ! .
 

·
Super Moderator
2006 Corolla XRS
Joined
·
7,425 Posts
Can you capture both O2 sensors? Wondering why yours is showing 0. Were you just idling?
 

·
Super Moderator
2006 Corolla XRS
Joined
·
7,425 Posts
Ok. That makes more sense. What is odd though that the LTFT should be closer to 0. I'd start looking into a vacuum leak.
 

·
Registered
05 camry 07 tacoma
Joined
·
2,550 Posts
Looks like your scan tool doesn't let you monitor live data?
The freeze frame shows LT plus ST fuel trims of +42 at 1100 RPM.
MAF looks normal around 7g/s at 1100RPM so suspect vacuum leak causing fuel trims to be high.
If you could monitor live data, fuel trims that decrease at higher RPM indicate vacuum leak.
If trims stay same then suspect maf or fuel delivery problem.

You have a mix of codes P0172 indicates rich the opposite of what the freeze frame shows now and P101 while 7 g/s is normal at 1100 RPM.
Best erase error codes and see what resets first.
Then determine if you have a vacuum leak. Lots of info out there on how to detect.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #19
Ok. That makes more sense. What is odd though that the LTFT should be closer to 0. I'd start looking into a vacuum leak.
OK im gonna look for a vacum leak this week and keeps you updated , thank you .
 

·
Registered
Joined
·
16 Posts
Discussion Starter #20
Looks like your scan tool doesn't let you monitor live data?
The freeze frame shows LT plus ST fuel trims of +42 at 1100 RPM.
MAF looks normal around 7g/s at 1100RPM so suspect vacuum leak causing fuel trims to be high.
If you could monitor live data, fuel trims that decrease at higher RPM indicate vacuum leak.
If trims stay same then suspect maf or fuel delivery problem.

You have a mix of codes P0172 indicates rich the opposite of what the freeze frame shows now and P101 while 7 g/s is normal at 1100 RPM.
Best erase error codes and see what resets first.
Then determine if you have a vacuum leak. Lots of info out there on how to detect.
im gonna run a test to check for vacum leak thank you
 
1 - 20 of 28 Posts
Top