Toyota Nation Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi everyone...

I'm newbie here...I don't know if my car (Toyota Cresta '90 w/ 1G-GE Engine) fits in this thread or not...:confused:

I'm just wanna ask about my engine (1G-GE)...I noticed smell of gasoline that come out from exhaust,probably a too rich mixture of air fuel.

I have ask some mechanic in my town and they say maybe it come from electronic temp switch fail...so my ECU read that my engine is stiil in cool cond,even my car is in hot situation...

My question is...is it true that electronic temp switch can do such that case? Where is the position of electronic temp switch? And how to judge (messurment) that my electronic temp switch is broke or not?

Thanks before...
I'm sorry for my english that not good...:thumbsup:
 

·
Cressida nut
91 Pickup (Hilux)2wd
Joined
·
4,586 Posts
it is certainly possible that the temp switch will cause that problem. however it is not the only thing that could cause it to run rich.

I don't know exactly where it is on the 1G engine but it will most likely be on or near the thermostat housing.

how to test: this is for the supra, but the resistance should be the same. http://cygnusx1.net/Supra/Library/TSRM/MK3/manual.aspx?S=FI&P=41
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
it is certainly possible that the temp switch will cause that problem. however it is not the only thing that could cause it to run rich.

I don't know exactly where it is on the 1G engine but it will most likely be on or near the thermostat housing.

how to test: this is for the supra, but the resistance should be the same. http://cygnusx1.net/Supra/Library/TSRM/MK3/manual.aspx?S=FI&P=41
" however it is not the only thing that could cause it to run rich... "

can you explain that to me please...
thanks before...:thumbsup:
 

·
Cressida nut
91 Pickup (Hilux)2wd
Joined
·
4,586 Posts
" however it is not the only thing that could cause it to run rich... "

can you explain that to me please...
thanks before...:thumbsup:
other possibilities:
-leaking injector (or more than one, including cold start injector)
-faulty fuel pressure regulator
-faulty AFM or MAF (electronics box between the air filter and throttle)
-faulty O2 sensor
-faulty wiring to just about any sensor
-faulty computer

I'm sure there's others but it's late and I'm tired.
 

·
Registered
88 Cressida
Joined
·
36 Posts
I worked recently with a cressida that i think it has that engine, is it the single cam?? 2.0l 6cyl? if so, inyection is very very easy, mostly if it comes without O2 sensor like the one i worked with, this one had rich mixture too, try checking leaking inyectors and all that stuff, maybe someone tried to adjust the mass airflow sensor but failed, adjust the screw (the one near the filter box) if there's no result, you can remove the black cap over the mass air flow sensor and adjust the plastic gear over there. The engine is wonderful, doesn't even need a valve cleareance adjustment, and it runs forever... bulletproof, hope you can get it on the road nicely.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Sorry for late reply...
I just wanna adding information about my engine...

My Engine series is 1GGE with twincam sitting on top of it...but there is no airflow meter on it...can someone figure it out?someone who might know about my engine...
 

·
Registered
Joined
·
39 Posts
I worked recently with a cressida that i think it has that engine, is it the single cam?? 2.0l 6cyl? if so, inyection is very very easy, mostly if it comes without O2 sensor like the one i worked with, this one had rich mixture too, try checking leaking inyectors and all that stuff, maybe someone tried to adjust the mass airflow sensor but failed, adjust the screw (the one near the filter box) if there's no result, you can remove the black cap over the mass air flow sensor and adjust the plastic gear over there. The engine is wonderful, doesn't even need a valve cleareance adjustment, and it runs forever... bulletproof, hope you can get it on the road nicely.
When u said 'it runs forever', I felt a tinge of regret coz 1've just swap the 1g- ge to 1ggteand now its has some boost running problem any idea?
 

·
Cressida nut
91 Pickup (Hilux)2wd
Joined
·
4,586 Posts
When u said 'it runs forever', I felt a tinge of regret coz 1've just swap the 1g- ge to 1ggteand now its has some boost running problem any idea?
you'll have to give a better description than that. you might want to start a thread of your own. in general turbo engines are all prone to similar problems... which is basically the same as any other engine plus a few. start looking at boost leaks, air-metering sensors, and spark plugs.
 

·
Registered
Joined
·
39 Posts
you'll have to give a better description than that. you might want to start a thread of your own. in general turbo engines are all prone to similar problems... which is basically the same as any other engine plus a few. start looking at boost leaks, air-metering sensors, and spark plugs.
Thanks.
 
1 - 11 of 11 Posts
Top