Toyota Nation Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
234 Posts
Discussion Starter #1 (Edited)
I'm bored and have nothing better to do. So I started this thread (like others have similarly in the PAST, but this is for NOW/Present, not from 2011, heh). It's always nice/cool to get up-to-date mileage polls from all you fine people, especially from the 200K+ group--but don't be shy, if you're not there yet--we/I <lol> still wanna know. So tell the world! How many miles (or km) do you have on your Echo? Let's see how many people respond with their numbers and make their Echos proud!

Please state the year and mileage of your Toyota Echo. Also color and if sedan or hatch if possible (Thank u @zythr!)



I'll go first.

2001 Toyota Echo (Auto) - 223K miles. Black-2Dr. coupe.
 

·
Registered
Joined
·
1,340 Posts
2-2000 blue coupes, granddaughter's has 213k miles, mine has 164k, both are manuals.

3rd is a 2001 dark green 4dr, also manual, just getting it road ready with 154k miles.

476k miles WOW! None of my 3 use oil, but they are babies compared to that number of miles.
 

·
Registered
Joined
·
10 Posts
Lol. I've taken it everywhere it's a very reliable car. When first got it salesman said just do the oil changes very little else to worry about. Got it in 01 and did first radiator change end of 2018. Even the original shocks were on till Jan of this year
 

·
Registered
Joined
·
18 Posts
I'm sort of embarrassed

2004, blue hatchback - 68,000k

Work off the internet, lot of what I need is local. 3 major malls within a few miles

DON
 

·
I Like Traffic Lights !!!
78 Bronco
Joined
·
520 Posts
2004 3 door Red hatchback, sold it with 454,000 kilometers on it (283,000 miles) and I still see it bombing around town. (sold it 2 years ago).
2005 3 door Silver hatchback, sold it with 132,000 kilometers on it. (82,500 miles)
2005 3 door Black Hatchback, sold it with 223,000 kilometers on it. (139,000 miles)
2005 4 door sedan dark blue that was totaled in an a accident, 303,000 kilometers on it. (189,375 miles)
 

·
Registered
Joined
·
29 Posts
2004 Echo RS hatch 5 speed (blue), 337K. Burns a teensy bit of oil, and only when it's cold (don't have to worry about it driving long distances). Mostly original I think, recently I replaced the tail light bulbs to see if they would get any brighter and they were the original bulbs (and the fresh replacements weren't any brighter lol).

Things for sure I replaced (I took possession of it around 300K): Both front wheel bearings, sway bar links, engine mounts, dashboard speakers (door speakers are still good), holding clip for the hood prop rod, and the bulb for the low temp light (initially I didn't even know that was a thing). Oh and the harmonic balancer which spun loose (suspect it was removed for some reason and not torqued down properly at some point in its life). EVAP is busted but "thanks" to Doug Ford it is a low priority

Edit: OK fine, A/C system doesn't hold pressure either. Will probably fix that in the next month or so

I'm sort of embarrassed

2004, blue hatchback - 68,000k

Work off the internet, lot of what I need is local. 3 major malls within a few miles

DON
I almost want to see what yours looks like compared to mine. I promise I won't steal any parts
 

·
Registered
Joined
·
18 Posts
2004 Echo RS hatch 5 speed (blue), 337K. Burns a teensy bit of oil, and only when it's cold (don't have to worry about it driving long distances). Mostly original I think, recently I replaced the tail light bulbs to see if they would get any brighter and they were the original bulbs (and the fresh replacements weren't any brighter lol).

Things for sure I replaced (I took possession of it around 300K): Both front wheel bearings, sway bar links, engine mounts, dashboard speakers (door speakers are still good), holding clip for the hood prop rod, and the bulb for the low temp light (initially I didn't even know that was a thing). Oh and the harmonic balancer which spun loose (suspect it was removed for some reason and not torqued down properly at some point in its life). EVAP is busted but "thanks" to Doug Ford it is a low priority

Edit: OK fine, A/C system doesn't hold pressure either. Will probably fix that in the next month or so



I almost want to see what yours looks like compared to mine. I promise I won't steal any parts

Had 3 wheel bearings replaced. Also had the gas down fill spout and shifter cable replaced. Neither of which I was happy with as this happened in year 8 and 9 and never had to do that with any of my previous cars.

Crappy painted rims are chipping. Lost some clear coat on the roof. Seems blue is the most problematic color for this to happen to. It's the color that shows up the most in a search on the problem

Somebody toss a small rock or flew off and up off a truck as there's a nice dent in the hood

Interior still nice and clean for 15 years





DON
 

·
Registered
Joined
·
29 Posts
Had 3 wheel bearings replaced. Also had the gas down fill spout and shifter cable replaced. Neither of which I was happy with as this happened in year 8 and 9 and never had to do that with any of my previous cars.

Crappy painted rims are chipping. Lost some clear coat on the roof. Seems blue is the most problematic color for this to happen to. It's the color that shows up the most in a search on the problem
If you had it since new then your relationship with the car is very different than mine! I didn't expect much but I didn't pay much for it either. I have those original wheels but not installed as at some point the exact same thing happened. If I wanted to spend the time I could maybe sandblast & plasti-dip them... but I don't. :p I see also the bottom of your doors are shedding rust in the same places... but your rear quarter panel looks perfect!
 

·
Registered
Joined
·
18 Posts
If you had it since new then your relationship with the car is very different than mine! I didn't expect much but I didn't pay much for it either. I have those original wheels but not installed as at some point the exact same thing happened. If I wanted to spend the time I could maybe sandblast & plasti-dip them... but I don't. :p I see also the bottom of your doors are shedding rust in the same places... but your rear quarter panel looks perfect!
No rust on the outside body, but do have some rusting on the inside door at the bottom

Forgot to mention, but 6 months after I got the car. Senior thought someone backing out of a parking spot was going to hit him, so his way of avoiding this was to put his car in reverse and step on the gas pedal. About $3500 damage to the front end

That was the only accident.

Better than the 6 weeks I owned my Tercel when I was rear ended at a stop light

DON
 

·
Registered
Joined
·
6 Posts
2002 Echo sedan, automatic. 295k miles. Still about 35 mpg in the city. I've had it since 2005, when I got it with 62k miles. No major repairs. Usual stuff. Oil changes every 5k miles and top off 7-8 ounces per 300 miles. AC compressor went out last summer, but not a big deal. I hardly ever used the air anyway. I use only non-ethanol gas, and it's definitely worth the extra .30 per gallon. Better mileage and better for the car.
 

·
Moderator
Joined
·
11,338 Posts
2002 Echo sedan, automatic. 295k miles. Still about 35 mpg in the city. I've had it since 2005, when I got it with 62k miles. No major repairs. Usual stuff. Oil changes every 5k miles and top off 7-8 ounces per 300 miles. AC compressor went out last summer, but not a big deal. I hardly ever used the air anyway. I use only non-ethanol gas, and it's definitely worth the extra .30 per gallon. Better mileage and better for the car.
Cool what color?
 

·
Registered
Joined
·
6 Posts
My Echo is white. It's only real blemish is the upholstery of the driver's seat that has holes from my butt over time. If I had some money that I wouldn't mind wasting, I would get new leather and foam for the seats.
 

·
Moderator
Joined
·
11,338 Posts
My Echo is white. It's only real blemish is the upholstery of the driver's seat that has holes from my butt over time. If I had some money that I wouldn't mind wasting, I would get new leather and foam for the seats.


That's cool, thanks
 

·
Registered
Joined
·
5 Posts
2003 Sedan, Auto, 145,000 Miles.

Uses oil
A/C won't hold a charge
It has been in a wreck, not salvage
Bought it for a cheap school car. $2500.

I don't know the MPG, my daughter drives it. She likes the fact that it is small, but that's about all! LOL
 

·
Registered
Joined
·
2 Posts
2003 echo sedan auto; 149k miles, some kinda grey color.

I'm almost positive this was a hurricane car, at the very least it was EXTREMELY wet for a little while. Bought it five days ago with 144k miles on it.

35mpg at 75-90mph for 9 gallons at a time (speed limit 80)

38mpg at 65 -80mph for 9 gallons at a time (speed limit 70)

I dried out the spark plug cylinders, replaced with NGK iridium plugs. Replaced every last vacuum line (2) but still sometimes idles high (I haven't idled much though, so not sure if it will still throw IAC codes)

Power steering reservoir is covered in grease, and some grease around the valve cover (any idea why? Valve cover gasket?) But doesn't use much, if any oil. Car will mostly sit for six weeks and then get another 3k miles on unknown oil. Then I'll either take care of it or run the absolute piss out of it caring not for any longevity maintenance. I just don't know anything substantial about this car yet. Would love to hit the 500k club with it though...

A/C works, fan speed adjuster works, heater works, all other HVAC controls do not function. Only blows from dash, no defrost, no air to floor vents. Cooling assembly is loose and when fan spins it rattles the cooling assemblies.

This thing has had its ass kicked. Runs great!
 

·
Registered
Joined
·
3 Posts
2001 Echo blue 4 dr sedan, automatic: 275k miles.
Runs strong
Various pesky electrical/trim things not working.
Burns some oil (maybe a quart every 2-3k miles).
Have had the a/c disconnected for the past 3-4 years after water pump replaced which has probably extended engine life.
A persistent intermittent check-engine light which nobody has quite been able to figure out yet (code says part of FI system too lean, but no one has been able to pin it down and it drives perfect, so....??).
 

·
Moderator
Joined
·
11,338 Posts
Just a quick question. Have any of you had any rust issues with your ECHOs? It seems that rust issues may be plaguing the 1st Gen xB that uses the same mechanicals as the ECHO.
 
1 - 20 of 26 Posts
Top