Toyota Nation Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone
I have a 1994 toyota pickup 4x4 4 cylinder 22?
The truck just died ...everything in my expierience tells me its the fuel pump...truck cranks over strong, but make no attempt to start.

The problem I am having is I cannot determine if the fuel pump is bad or not...disconnected the fuel feed lines before the fuel filter and after the fuel filter...the mystery is I get fuel only when the engine is cranking(shouldnt the the pump turn on from accy power?) on a electric fuel pump?

Someone mentioned to me that maybe the inertia switch tripped? Where is that?

Any help to point me in the right direction would be helpful...I really hate taking this thing to a shop...

Thanks in advance
 

·
Registered
Joined
·
38 Posts
If your truck is fuel injected turn the ignition "on" and go to the rear of the truck by the gas tank if you hear any type of hum you can be assured its not the fuel pump. Try replacing the filter its a 3 dollar part give or take.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I am getting fuel out of the filter...a strong spray. Just replaced it about 6 months ago.

Thankyou, I really dont believe its the filter. Why is fuel only pumping when the engine is cranking? is that normal operation?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
About 140,000...could be a timing issue...this engine has the timing chain...not that they dont break, but ...
 

·
Registered
Joined
·
38 Posts
thats about the time that some of them do let go during. Ive replaced my fair share of them to check easiest thing to do is remove the valve cover its only 4 bolts. size 12 metric just make sure you dont overtighten when you place them back on. Another thing you can remove the cover without removing the vacuum lines but you will have to seperate the sensor relays from the valve cover but will not have to take them off the rubber lines.
 

·
Toyota Fixer
TOYOTA
Joined
·
64 Posts
Sounds like a timing issue. Also I have had a problem with the pin that holds the cam to the timing chain sprocket breaking off and therefore spinning the bottom end and the top end staying still. Definately remove the valve cover.
 

·
Registered
Joined
·
31 Posts
i had a older yota and on the 22r motor the fuel pump was mechanical i believe, but if yours is injected which it probably is you probably have an electric pump. if the truck is a carb. then they fuel pump may not be the problem..... just an idea?
 

·
NY born, Texas raised
Joined
·
705 Posts
On my '86 4runner, 4cyl EFI, the fuel pump does NOT turn on with the key. It only pumps when it senses air movement at the mass air flow box, engine cranking. No cranking, no air flow, no fuel pumping. There is a connector under the hood on my truck that can be jumpered to turn ON the fuel pump with just the key on. Maybe yours has one also, but the fuel pump does NOT sound like your problem.
Check for spark.
Did you just fill the tank? Bad gas?
Let us know what you find.
 
1 - 11 of 11 Posts
Top