Toyota Nation Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
here is my problem hope you guys can help me out!

Driving on the highway going about 70 mph and getting off at an exit and stepping on the brakes lightly and the car vibrates!

The camry is a 2000 with about 45,000 miles on it the front tires are two yrs old and the front brakes were doen about 2-3 thousands miles ago. The rear tires were the same ones that came with the car and brakes were not change yet. I was thinking it is the rotor or my rear tires that is causing the problem.

What do you guys think?

Thanks for any input!

Azn
 
2005 Tacoma X-Runner
Joined
·
9,188 Posts
Did you have the rotor's resurfaced when you had the pads changed? Did you use dealer pads or ceramic? Doesn't sound like the tires because it only happens when you use the brakes.
 

·
Know God. Work Hard.
4Runner
Joined
·
2,195 Posts
I have the same problem but Im pretty sure that my brakes are just worn down. Im changing them tommorrow and Ill tell you what happens.

Bump this thread after a day or two to remind me to post up if its gone or not.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #6 ·
thanks for all the help guys I think I'll switch out the rotors and see what happens. Does any1 know of a good brand to go with or how a set of toyota front and rear rotors will run me!

Azn
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top