Toyota Nation Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2002 Toyota Highlander with about 50,000 miles. We are the second owners, (have had car about 2 months.) Problem; VSC light, check engine light and "Trac off" lights have all come on. I pushed the button for Trac Off and nothing happens. I don't want to have to spend a ton of money just to get these lights to turn off. .. or is it something major Help! thanks so much, PT
 

·
Registered
Joined
·
38 Posts
I have the same issue with my 2006 at 230k miles. I went to Autozone for a scan and they said gas cap. Made no friggin sense, but they aren't diagnosticians. Replaced the cap. Now it won't idle and stalls. After a week of youtube bs on resetting the codes, I went to a dealer and had them run a FULL scan for $169. New gas cap was leaky, so bought OEM. Idle and stalling is fixed for three weeks and 2,100 miles so far. However, the VSC and Trac Off both had codes. Per Toyota it is either a brake switch ($415 for part) or the ECU ($3200 for part). They recommend switch then ECU. I need to find which switch and try replacing it. I can't see $3,600 going into this car, but I understand now why I see some pristine Highlanders in junkyards.
 

·
Registered
Joined
·
38 Posts
I have the same issue with my 2006 at 230k miles. I went to Autozone for a scan and they said gas cap. Made no friggin sense, but they aren't diagnosticians. Replaced the cap. Now it won't idle and stalls. After a week of youtube bs on resetting the codes, I went to a dealer and had them run a FULL scan for $169. New gas cap was leaky, so bought OEM. Idle and stalling is fixed for three weeks and 2,100 miles so far. However, the VSC and Trac Off both had codes. Per Toyota it is either a brake switch ($415 for part) or the ECU ($3200 for part). They recommend switch then ECU. I need to find which switch and try replacing it. I can't see $3,600 going into this car, but I understand now why I see some pristine Highlanders in junkyards.
I have the same issue. 240,000 miles and they say brake switch or ecu. I just read that an air hose or vac line on the airfilter housing will cause it. I'll check in the morning. I can get a reprogrammed ecu for $300. No way I'm giving a dealer $3,500 to guess at parts when I can do it for $300. I still don't know where this first guess brake switch is.
 
1 - 3 of 3 Posts
Top