Toyota Nation Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Hi,Guys,my 92 3vzfe got the problem recently.When the engine is cold(i.e.every morning),after I start it and give gas to move,I can hear some waterflow noise and some electric current sound,but after a while(3-4 minutes),when the engine warms up,no more noise can be heard.I m not sure it is from coolant or fuel.About 1 month ago,I changed a fuel injector for misfire. And the car had a overhearing issue before the misfire was fixed.The electric current noise from driver side,sounds like under the wheel. Thank you in advance for any help.
 

·
イリジウム
Joined
·
13,497 Posts
There may be some air in the system. With the engine cold, remove the radiator cap and see if the coolant is filled up to the radiator neck. With the radiator cap off, inspect the little plastic valve (vacuum return valve) and make sure there is no debris around it. Make sure it can seal against the larger pressure relief valve. Check for evidence of water pump leaks. Turn on the AC (with the engine running) and see if both fans work. If these all checked out, then I wonder if it's head gasket related.
Hi,Guys,my 92 3vzfe got the problem recently.When the engine is cold(i.e.every morning),after I start it and give gas to move,I can hear some waterflow noise and some electric current sound,but after a while(3-4 minutes),when the engine warms up,no more noise can be heard.I m not sure it is from coolant or fuel.About 1 month ago,I changed a fuel injector for misfire. And the car had a overhearing issue before the misfire was fixed.The electric current noise from driver side,sounds like under the wheel. Thank you in advance for any help.
 
1 - 2 of 2 Posts
Top