Toyota Nation Forum banner

121 - 140 of 5475 Posts

·
Lord of the Sith
Joined
·
1,085 Posts
I already bought the paint yesterday :lol:

but why the opposition to red, and what do you suggest instead?
I want to hear your thoughts on this
 

·
Lord of the Sith
Joined
·
1,085 Posts
ah
I was thinking Red Valve, black plastic, with red toyota logo
 

·
Lord of the Sith
Joined
·
1,085 Posts
oh, forgot to add





Excuse the rust spots on the discs, the car has been sitting since april 27th

and...


OH NOES, WHERE DOES MY WING GOES??
:naughty:
 

·
Lord of the Sith
Joined
·
1,085 Posts
Paypal should go through on tuesday; figure another week, maybe 2 for shipping.

Can't wait for em to be here though :D
 

·
TN's Mad Chemist
Joined
·
3,125 Posts
New Brembo rotors, Brembo pads (courtesy of Ken:thumbsup:, thanks again buddy!), new dogbone mount and new front hydraulic engine mount.

The last bolt on the front hydraulic engine mount was a b**ch to get off because of the fact that it's right below the motor for the radiator fan:headbang:

Started at 11:00. Finished at 2:30 in the morning :lol: Took my sweet old time cause I know i was tired as hell :lol:
 

·
96 3MZ M/T
Joined
·
2,879 Posts
had to tap this out hope to god the bolt on the engine is M12x1.50 the front bolt on the mount from the underside is M12x1.25 :eek:



oh and this is why :eek:



not pictured is the front mount bolt that's also destroyed
 

·
Registered
Joined
·
1,593 Posts
Over the last few days, replaced large gauge bulbs with LED bulbs (again). Put some of my interior back in... and today, replaced oil/filter, oil pan gasket, and oil pickup screen.
 

·
Registered
Joined
·
5,344 Posts
JESUS.

What did you do? Try taking the engine out with the mounts still attached?
 
121 - 140 of 5475 Posts
About this Discussion
5.5K Replies
584 Participants
guapoman2000
Toyota Nation Forum
ToyotaNation Forum is a community dedicated to all Toyota models. Come discuss the Camry, Tacoma, Highlander, 4Runner, Rav4 and more!
Full Forum Listing
Top