Toyota Nation Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I just want a confirmation, are 94-95-96 Camry wiring harness the same? As in share the same engine related plugs to the 1mzfe (v6). I would imagine so as I have done a lot of research from LS400's and the harnesses for ls400 are pretty much the same up to vvt-i. But different from SC400's (which are all similar throuhg the years up to vvt-i) and so on for other 1uz (V8) vehicles.

Thanks
 

·
TN Pussy Man
Camry
Joined
·
13,302 Posts
maybe...? but I'm not sure either....

because they changed the 1mz slightly between the very first one, 94, and the 95/96 one
 

·
I'm a Mac
DD - 94 Mitsu 3000GT
Joined
·
4,062 Posts
i believe the main engine functions are consistant with 94-96 v6 engine harnesses. i know it minorly changes between 94 and 95, but i think the main engine functions are all the same.

i am not positive on this, please dont quote me for 100% truth.

just know that with any swap you do there are going to be wiring setbacks that are very costly in time and effort. even if you know wiring well.
 

·
Registered
Joined
·
1,658 Posts
One differece I can think of off the top of my head is that you will have to accomodate wiring for the sub-oxygen sensor. There shouldn't be too many diferences though. Just take a good look at both ECU pinouts and you should be good to go.
 

·
I'm a Mac
DD - 94 Mitsu 3000GT
Joined
·
4,062 Posts
there is a sub o2 starting in 92 v6, it is just more needed after the obd1 when they started obd2 in 94 v6 for stable control with the ecu and it stayed that way throughout gen 4 as well.
i think in the 5sfe wiring, they started with a sub o2 in 95 though...
and lou, you might be confused cause my car doesnt have one and its a 94... welll i never wired it in... i thought you knew that.
 

·
Registered
Joined
·
1,658 Posts
zoni said:
there is a sub o2 starting in 92 v6, it is just more needed after the obd1 when they started obd2 in 94 v6 for stable control with the ecu and it stayed that way throughout gen 4 as well.
i think in the 5sfe wiring, they started with a sub o2 in 95 though...
and lou, you might be confused cause my car doesnt have one and its a 94... welll i never wired it in... i thought you knew that.

yea you're right its was the 5sfe that doesn't have the sub-O2 before 95

yea i knew you didn't wire it in you bastard, but what else is new:p:
 
1 - 6 of 6 Posts
Top